The Chocolate Life

Discover Chocolate and Live La Vida Cocoa!

I am sure this is a horror story that has been discussed many times over - but it is a first for me.... And, I woke up this morning - and the problem still hasn't worked itself out.

The details:  I tempered dark chocolate last night.  Filled a brand new polycarb mould (just arrived yesterday from TOMRIC) with tempered chocolate.  This is my first time ever using polycarb moulds (so - I may actually be the problem, not the mould.)  I set the mould in a 68F room with a light flow from a fan across the mould.  After 10 minutes, I put the mould in the refrigerator.  After 20 minutes the choc wouldn't release - so in desperation I put mould in freezer.  Checking every 10 minutes - still no release.  I gave up after 30 minutes and put the mould in the refrigerator for overnight.  This morning - still no release and my husband suggested tapping gently with a blow hammer to the bottom.  HELP.

Views: 48

Replies are closed for this discussion.

Replies to This Discussion

I was under the impression that Tomric offered nothing but thermoformed molds, and not polycarbonate.  I could be wrong. 

 

Regardless, I suspect the challenge is that your chocolate wasn't properly tempered.

 

Did you test for temper before molding?  I highly recommend this for people just getting started in working with chocolate.

 

Can you post a picture of the mold?

This discussion was (for some reason) continued here

This discussion has been closed to further comments. Please add any comments to the new discussion.

RSS

Member Marketplace

Promote TheChocolateLife

Bookmark and Share

Follow Clay on:
Twitter :: @DiscoverChoc
F'Book :: TheChocolateLife
F'Book Group :: LaVidaCocoa
Paper.li :: @DiscoverChoc

Badge

Loading…

© 2014   Created by Clay Gordon.

Badges  |  Report an Issue  |  Terms of Service