The Chocolate Life

Discover Chocolate and Live La Vida Cocoa!


I purchased a Chocovision MiniRev and all of a sudden when I plug it in, and set everything up the lights are blinking but when I push the selection button it doesn't do anything. It will cost more to send it back to chocovision than it did to purchase it and they wouldn't troubleshoot it with me over the phone...any suggestions?


Views: 126

Replies to This Discussion
Their FAQ page might help.
I suspect the baffle is not plugged in correctly. Check the pins & see if you can find something.
I haven't worked with a mini rev but this may help.
Thanks Larry. I have a new baffle so I don't think that is the issue. I tried all 3. If it was the baffle the lights would not be blinking. I appreciate your reply.
Does it have a reset button on it somewhere? If it does maybe it just needs to be reset. Are one of the buttons stuck? Maybe when a button was pushed it didn't release all the way.
There is a known fault with the Rev2 - if you turn it on and get EE on the read out, then do anything except hit the reset button, it will burn out the heater motor, it's then an expensive repair. It's one of those many Chocovision bugs that they seem reluctant to fix.


Member Marketplace

Promote TheChocolateLife

Bookmark and Share

Follow Clay on:
Twitter :: @DiscoverChoc
F'Book :: TheChocolateLife
F'Book Group :: LaVidaCocoa :: @DiscoverChoc

© 2014   Created by Clay Gordon.

Badges  |  Report an Issue  |  Terms of Service